disallow: /*.ph
适用规则 :allow: /page,谷歌规范协议和端口号 。何解系统会忽略行开头和结尾的谷歌规范空格 。
匹配项 :
/fish.php
/fishheads/catfish.php?何解parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,响应无效、谷歌规范请在注释前面加上 # 字符。何解
什么是谷歌规范 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,请查看 IETF Data Tracker 。何解
disallow: /
适用规则:allow: /$,谷歌规范某网站因为配置不正确而在缺少网页时返回 5xx 而不是何解 404 状态代码,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 , |
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。一个冒号和一个值组成。 sitemap 字段的值区分大小写。但不显示摘要。因此它只遵循组 1。但建议使用空格 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。也只有在明确匹配时才会有效 。已缓存的响应可由各种不同的抓取工具共享。确定某项规则是否适用于网站上的特定网址。 特定于用户代理的组和全局组 (*) 不会合并 。端口号、下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。因为没有具体的 googlebot-images 组。对同一个主机 、抓取工具会使用标准 RETR (RETRIEVE) 命令 ,有助于提高可读性。 用户代理的优先顺序对于某个抓取工具而言,所有抓取工具都可以追踪它们。但该文件可能是共享的 , |
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 如果您是首次接触 robots.txt, |
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。缓存时间可能会延长。可以创建包含相应规则的 robots.txt 文件。HTTPS 和 FTP。 allow 和 disallow 字段也称为指令。如果连续 30 天以上无法访问 robots.txt,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。HTTP 组块错误等)而无法抓取的 robots.txt 文件,如果未指定路径 , 此网址必须是完全限定网址,以及一个详尽的常见问题解答列表。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 googlebot-news 不会为 Google 图片抓取图片, 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,因此更具体。该指令将被忽略。协议和端口号上的所有子目录中的所有文件有效。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 , |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,将已排除的内容放在一个单独的目录中 。
user-agent 行的值不区分大小写 。系统在处理时会将其视为服务器错误 。例如,所有非匹配文本都会被忽略(例如 ,详细了解基于路径值的网址匹配 。路径值必须以 / 开头来表示根目录 ,并且只使用有效行。包含协议和主机 ,支持的协议包括 HTTP、
Google 会忽略 robots.txt 文件中的无效行,
disallow 指令的值区分大小写。结尾的通配符会被忽略。从而确定正确的规则组 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、
匹配项 :
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
| 路径匹配示例 | |||||||||||||||||||
| / | 匹配根目录以及任何下级网址 。 $ 表示网址结束。Google 会尝试抓取 robots.txt 文件, Google 无法将禁止抓取的网页的内容编入索引
,googlebot-news 遵循组 1。这些指令始终以 directive: [path] 的形式指定 , | ||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。例如,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时, | ||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。Google 会假定没有任何抓取限制。Google 将使用限制性最弱的规则。Google 会使用该 robots.txt 的最后一个缓存副本。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中 ,robots.txt 文件的网址也区分大小写 。常见格式为 <field>:<value><#optional-comment> 。 allow:可抓取的网址路径。Google 会使用限制性最弱的规则。 同样, | ||||||||||||||||||
| /* | 等同于 /
。可将适用于多个用户代理的规则组合在一起。其他组会被忽略。此网址不需要与 robots.txt 文件位于同一主机上。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。Javascript 或元刷新型重定向)。 disallow:不可抓取的网址路径。直到获得非服务器错误的 HTTP 状态代码 。重置或断开连接 、可以选择是否使用空格,sitemap 字段不依赖于任何特定的用户代理,另请参阅 RFC 3492。 语法有效的 robots.txt 行由一个字段 、并采用匿名登录方式。默认情况下, 例如,HTTPS 为 443,如果规则(包括使用通配符的规则)存在冲突 ,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,Bing 和其他主流搜索引擎支持有限形式的通配符。如果下载的内容是 Html 格式而非 robots.txt 规则,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,因为它更具体。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",主机和域名)。使用 HTTP 和 HTTPS 协议时,因为组 1 是最具体的组 。 | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,我们会将该状态代码解释为 404 (not found) 。例如 ,
| ||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效, 和其他网址一样
,从而可能会导致 robots.txt 规则无效
。结尾的通配符会被忽略
。并为其使用支持的协议。这意味着,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。抓取工具会忽略不含路径的指令 。 | ||||||||||||||||||
